Vulnérabilités relatives au protocole NTP

Numéro : AL14-041
Date : Le 20 décembre 2014

Objet

La présente alerte vise à vous informer de la version vulnérable du protocole NTP (Network Time Prototcol)

Évaluation

Le CCRIC a été informé de vulnérabilités récemment divulguées dans le protocole NTP. Les versions 4 antérieures à la version 4.2.8 du protocole NTP sont vulnérables et doivent être remplacées par la version 4.2.8. La version NTP 4.2.8 règle quatre points vulnérables. Le plus grave est le fait que CVE 2014-9295 (dépassement de tampon) pourrait permettre à un pirate d’exécuter un code arbitraire accordant les mêmes privilèges que le processus NTP. Comme certains fournisseurs du NTP ne sont pas touchés, le CCRIC recommande aux administrateurs de consulter leur fournisseur pour vérifier si leur système est vulnérable et pour obtenir le correctif de sécurité.

CVE-2014-9293 : Clé aléatoire avec entropie insuffisante
Si la clé d’authentification n’est pas au dossier de configuration, le processus ntpd créera une clé aléatoire faible dont l’entropie est insuffisante.
Références CVE : CVE 2014-9293
Versions touchées : Toutes les versions antérieures à la version NTP-4.2.7p11
Référence : http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-9293

CVE- 2014-9294 : Valeur d’amorçage faible
La fonction ntp-keygen a recours à une valeur d’amorçage faible pour créer aléatoirement les nombres utilisés par l’algorithme de création de clés.
Référence CVE : CVE 2014-9294
Versions touchées : toutes les versions antérieures à NTP-4.2.7p230
Référence : http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-9294

CVE-2014-9295 : Dépassement de tampon
Un paquet unique bien conçu pourrait entraîner le dépassement du tampon et permettre qu’un code arbitraire soit traité comme un processus ntpd.
Référence CVE : CVE-2014-9295
Versions touchées : Toutes les versions antérieures à la version stable NTP 4.2.8
Référence : http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-9295

CVE-2014-9296 : Défaut d’arrêt d’exécution
La fonction de réception continue d’exécuter les codes, même après avoir perçu une erreur d’authentification précise.
Référence CVE : CVE-2014-9296
Versions touchées : Toutes les versions antérieures à la version stable NTP 4.2.8

Mesures Recommandées

Le CCRIC recommande aux organisations qui ont recours aux services du NTP avec une version antérieure à la version NTP-stable 4.2.8 de considérer sérieusement mettre à jour leur logiciel à la version la plus récente, immédiatement après avoir évalué l’incidence des vulnérabilités sur leur milieu de travail réseau et leurs exigences opérationnelles. Plusieurs fournisseurs ont commencé à offrir des correctifs. Veuillez consulter votre fournisseur pour obtenir des renseignements afin de parer à ces vulnérabilités.

Un correctif est disponible :
Voici la version la plus récente du protocole NTP : http://support.ntp.org/bin/view/Main/SoftwareDownloads

Références :

Avis de vulnérabilité VU#852879 :
Référence : http://www.kb.cert.org/vuls/id/852879      

Renseignements sur le fournisseur VU#852879 :
Référence : http://www.kb.cert.org/vuls/byvendor?searchview&Query=FIELD+Reference=852879&SearchOrder=4

Note aux lecteurs

En appui à la mission de Sécurité publique Canada de bâtir un Canada sécuritaire et résilient, le mandat du CCRIC est d'aider à assurer la sécurité et la résilience des cybersystèmes essentiels non gouvernementaux à la base de la sécurité nationale, de la sécurité publique et de la prospérité économique du pays. À titre d'équipe d'intervention en cas d'incident lié à la sécurité informatique du Canada, le CCRIC agit comme centre national de coordination pour la prévention, l'atténuation, l'intervention et le rétablissement liés aux incidents cybernétiques commis contre des systèmes non fédéraux. Pour ce faire, il formule des conseils éclairés, offre du soutien et coordonne l'échange de renseignements ainsi que l'intervention.

S'il vous plaît noter que la clé PGP du CCRIC a récemment été mise à jour.
http://www.securitepublique.gc.ca/cnt/ntnl-scrt/cbr-scrt/_fl/CCIRCPublicPGPKey.txt

Pour obtenir des renseignements de nature générale, veuillez communiquer avec la division des Affaires publiques de l'organisme :

Téléphone : 613-944-4875 ou 1-800-830-3118  
Télécopieur : 613-998-9589 
Courriel : ps.communications-communications.sp@canada.ca

Date de modification :