Vulnérabilités des versions antérieures à la version 1.2.7 de l’application PHP WebCalendar

Numéro : AV14-099
Date : Le 05 décembre 2014

Objet

L'objet du présent avis est d'attirer votre attention sur des vulnérabilités connues des versions antérieures à la version 1.2.7 de l'application PHP WebCalendar, ainsi que sur les risques qui peuvent en découler lors du déploiement.

Évaluation

Des chercheurs en sécurité ont remarqué qu’un nombre important de sites Web hébergeant des maliciels et les pages de phishing le font en raison de vulnérabilités connues des versions antérieures à la version 1.2.7 de l’application PHP WebCalendar. Le fait d’héberger une version désuète de l’application sur votre réseau présente un risque pour votre réseau et pour toute personne qui y accède.

L’application PHP WebCalendar sert à tenir à jour les calendriers d’utilisateurs ou de groupes d’utilisateurs intranet. Cette application est très répandue sur Internet et a été téléchargée plus d’un million de fois depuis sa première diffusion.

Les attaquants malveillants ciblent les installations publiques accessibles de WebCalendar et en exploitent les vulnérabilités pour diffuser leurs fichiers malveillants sur des domaines et des URL légitimes. Après avoir exploité les vulnérabilités d’un hôte qui exécute WebCalendar, l’attaquant téléverse des fichiers malveillants. Il diffuse ensuite l’URL menant aux fichiers malveillants à des utilisateurs sans méfiance au moyen d’un nom de domaine légitime, mais désormais compromis, pour déguiser le téléchargement des fichiers malveillants.

Références CVE : CVE-2013-1421, CVE-2012-5385, CVE-2012-5384

Mesures Recommandées

On recommande aux administrateurs de serveur exécutant une version antérieure à la version 1.2.7 de WebCalendar de passer à la version 1.2.7, étant donné que les versions antérieures présentent diverses vulnérabilités en matière de sécurité.

Références (en anglais)

Note aux lecteurs

En appui à la mission de Sécurité publique Canada de bâtir un Canada sécuritaire et résilient, le mandat du CCRIC est d'aider à assurer la sécurité et la résilience des cybersystèmes essentiels non gouvernementaux à la base de la sécurité nationale, de la sécurité publique et de la prospérité économique du pays. À titre d'équipe d'intervention en cas d'incident lié à la sécurité informatique du Canada, le CCRIC agit comme centre national de coordination pour la prévention, l'atténuation, l'intervention et le rétablissement liés aux incidents cybernétiques commis contre des systèmes non fédéraux. Pour ce faire, il formule des conseils éclairés, offre du soutien et coordonne l'échange de renseignements ainsi que l'intervention.

S'il vous plaît noter que la clé PGP du CCRIC a récemment été mise à jour.
http://www.securitepublique.gc.ca/cnt/ntnl-scrt/cbr-scrt/_fl/CCIRCPublicPGPKey.txt

Pour obtenir des renseignements de nature générale, veuillez communiquer avec la division des Affaires publiques de l'organisme :

Téléphone : 613-944-4875 ou 1-800-830-3118  
Télécopieur : 613-998-9589 
Courriel : ps.communications-communications.sp@canada.ca

Date de modification :